grThumb v.1.0.5 is up for grabs

this is “hotfix” release to address some of the errors discovered in 1.0.4 and better handle metadata in “overlay” mode

+ Admin: Metadata Display Mode extended to allow exclusion of Catalog Description from the Thumb content
– Fixed issue with some js variables not being initialized when big thumb mode is used
– Fixed issue when “Big Thumb” in Square mode does not keep size ratio

Enjoy


6 Comments

Neil · Sep 6, 2014 at 14:43

Thanks for the update.

I am still experiencing an issue though it has changed somewhat:

If I select ‘Scale thumbnails – Square’ and check ‘Double the size of the first thumbnail’ the thumbnails display correctly.

If I select ‘Scale thumbnails – Square’ and uncheck ‘Double the size of the first thumbnail’ the thumbnail for the first folder is not displayed, i.e. I have 3 folders named 2014, 2013 and 2012. 2013 and 2012 display correctly but 2014 (top of the sort order and in my case also with the lowest folder ID) fails to display.

    Serguei Dosyukov · Sep 6, 2014 at 15:57

    link? hard to say what issue could be

      Neil · Sep 7, 2014 at 08:16

      http://neiljacklin.com/piwigo/

      Current settings

      Masonry Type: Horizontal
      Thumbnails max height (px): 200px
      Margin between thumbnails px: 10
      Number of photos per page: 12

      Double the size of the first thumbnail: Unchecked
      Cache the big thumbnails (recommended): Checked
      Normalize Photo Title: Checked

      Scale thumbnails: Square
      Title Display Mode (Album): Overlay top
      Title Display Mode (Photo): Overlay top
      Metadata Display Mode: Hide

      I have deactivated and reactivated gdThumb 1.0.5 and rebuilt the cache.

      The above settings provide correctly displayed thumbnails but the 2014 folder thumbnail is not displayed.

      If I check ‘Double the size of the first thumbnail’ the thumbnails and the 3 folders display correctly.

      Neil · Sep 7, 2014 at 08:21

      Just realised that with the settings above, after clicking on the album thumbnails the photo thumbnails fail to display.

      Neil · Sep 7, 2014 at 08:41

      Albums 2012 and 2013 only contained a single photo in each so I added another photo into each album:

      Now Album 2014 still does not display, but Albums 2012 and 2013 display the album thumbnails. When I click on the album thumbnail only the first photo thumbnail in each album is displayed though clicking the photo thumbnail displays the photo and will click through to the second photo.

Serguei Dosyukov · Sep 7, 2014 at 11:57

Ok, issue has been identified and fixed in 1.0.6 posted

Leave a Reply

%d bloggers like this: